Unable to create MusicService

Bugs/crashes/problems with Beats go here. Check the FAQ and use the search function before posting.

Unable to create MusicService

Postby celeritax on Jun 29th, '11, 15:14

MuiscService not initialized

status: 0x1

This happens when i try to run this .osu file

I've tried restarting my phone, killed all apps etc, redownloaded the file. Nothing seems to work.

Also, off-topic: Is it possible to donate? When I click on the paypal button, it takes me to the paypal default login and then to my account profile. The script doesn't work.

P.S: my phone is a HTC Desire Z
Posts: 4
Joined: Jun 29th, '11, 15:09

Re: Unable to create MusicService

Postby xwingace on Jun 29th, '11, 16:07

I have no problems opening this file (I have problems playing it, but that's because I suck.) I get no error messages, just the arrows/circles depending on mode.

In [url=http://beatsportable.com/forum/viewtopic.php?f=12&t=846]this thread[url] Keripo suggests turning your phone completely off and restarting, but it looks like you already tried that. So then I got nothing.

Samsung Galaxy Apollo on this end.

Anti-spam mod. PM me if you think I missed something.
Posts: 25
Joined: Feb 8th, '11, 12:02

Re: Unable to create MusicService

Postby celeritax on Jun 30th, '11, 12:41

I can confirm that I've tried other .osu files, and they all worked perfectly. It's just this one file that won't work, and it applies to both osu mod activated and default (SM).

So it's probably something with my phone and this file? I have a hard time believing it, as it plays fine on Osu! on my computer.

Very, very strange.
Posts: 4
Joined: Jun 29th, '11, 15:09

Re: Unable to create MusicService

Postby keripo on Jul 17th, '11, 03:47

Seeing as it works fine for other people on other phones, I'd say its most likely an OS issue. For playback of music, I use the System's MusicService, which may have different implementations/performance on different phones. It might just happen that your phone does not support playback of the .mp3/.ogg file used in that osu beatmap package. Try re-encoding the mp3 file with a PC program (like foobar2000).

In the future, I may end up implementing my own music player (and possibly even video player).

Also, thanks for the note on the Donate page (no wonder why I've never received any donations), it should be working now!

User avatar
Site Admin
Posts: 115
Joined: Nov 7th, '10, 03:38
Location: [pengp@stwing~]

Return to Support

Who is online

Users browsing this forum: No registered users and 0 guests