Bugs in tap detection

Bugs/crashes/problems with Beats go here. Check the FAQ and use the search function before posting.

Bugs in tap detection

Postby burdik on Jan 16th, '11, 13:08

sometimes it just goes wierd 4 me as i get an 'pefrect' or 'good' or 'great' tap and... an immediate miss on the same arrow?!
An another problem 4 me is that the adjacent holds just aren't working without Tapbox overtap, the same goes 4 the holds with an arrow on their adjacent sides (i just can't push the arrow while holding teh hold)
I'm using Moto Milestone with The FroyoMOD v2.2.0, with 4 point multitouch hack which IMHO seems to cause the second problem but the first is a mystery 4 me :shock:
-=Russia is very large and cold place somewhere in the Arctics, inhabited by drunken bears firing nukes left, right and center.=-
User avatar
burdik
 
Posts: 19
Joined: Jan 16th, '11, 12:49
Location: Moscow, USSR =D

Re: Bugs in tap detection

Postby GunmanZ on Jan 21st, '11, 12:01

i think i got something similar??
I'm playing it to death with a samsung i9000 (UK version, stock Vodafone 2.2)
when i play songs on Challenge difficulty and when there are like 4 or 5 note followed together , it seems to stuck and doesn't register me doing the arrows :|
GunmanZ
 
Posts: 2
Joined: Jan 21st, '11, 11:56

Re: Bugs in tap detection

Postby Zurek on Jan 22nd, '11, 18:51

burdik wrote:sometimes it just goes wierd 4 me as i get an 'pefrect' or 'good' or 'great' tap and... an immediate miss on the same arrow?!

I have this problem too :( bu only on ver 1.4 and 1.4.1 , on 1.3 is all ok.
Image
Image
Anime-Planet.com - anime | manga | reviews
User avatar
Zurek
 
Posts: 7
Joined: Jan 22nd, '11, 18:05
Location: Elbląg, Poland

Re: Bugs in tap detection

Postby keripo on Jan 23rd, '11, 05:03

Zurek wrote:
burdik wrote:sometimes it just goes wierd 4 me as i get an 'pefrect' or 'good' or 'great' tap and... an immediate miss on the same arrow?!

I have this problem too :( bu only on ver 1.4 and 1.4.1 , on 1.3 is all ok.

Can you link me to an example song where the miss bug is very clear (and preferably near the beginning of the song so I can test it out multiple times)? Include settings and difficulty level.

GunmanZ wrote:i think i got something similar??
I'm playing it to death with a samsung i9000 (UK version, stock Vodafone 2.2)
when i play songs on Challenge difficulty and when there are like 4 or 5 note followed together , it seems to stuck and doesn't register me doing the arrows :|

This is purely due to lag and the current unoptimized/slowness of Beats. Tap registration is independent of in-game timeflow, meaning if your phone lags, even if you physically tap in time, the phone may register the taps too late compared to the note's expected time. The real problem is really that I only have one phone, and its a good phone that doesn't lag (Samsung Captivate), so fixing/improving lag issues will be difficult/impossible until we somehow get enough donations to buy an old/crappy Android phone off eBay or something.

~Keripo
Image
User avatar
keripo
Site Admin
 
Posts: 115
Joined: Nov 7th, '10, 03:38
Location: [pengp@stwing~]

Re: Bugs in tap detection

Postby Zurek on Jan 23rd, '11, 09:39

Ok, meybe look this song, but miss bug is randomly :p
On hard mode.
http://www.stepmania.com/download.php?f ... each.smzip

And the new bug, in this song
http://www.stepmania.com/download.php?f ... down.smzip
On beginning arrows "jump" from down to top oO . Bug only in ver 1.4+. Look On chellenge mode.

In setting i off holds, i change music ofset -325, show score in %, fullscren on.

Tested on samsung i5700.
User avatar
Zurek
 
Posts: 7
Joined: Jan 22nd, '11, 18:05
Location: Elbląg, Poland

Re: Bugs in tap detection

Postby keripo on Jan 23rd, '11, 17:32

Zurek wrote:Ok, meybe look this song, but miss bug is randomly :p
On hard mode.
http://www.stepmania.com/download.php?f ... each.smzip

I've played the song a few times and seem to have encountered a few misses at the particular note: (ignore this - its for my own notes)
Code: Select all
TAP_NOTE 1/8 B @ 25962 b4.850000e+01

It seems to be inconsistent and difficult to replicate, however. Only missed a total of 4 times over the ~20 times I tried (the other times were all full combos, so it could be a gameplay bug and not me being off-beat). Will take a closer look into it. It may, however, just be a difficult sequence of notes and you aren't actually tapping it properly. The best way to test for that is to turn Vibrate on Miss off. Also turn on Timing Debugging in Advanced Settings to see the details of the note that you are missing and post it here.

And the new bug, in this song
http://www.stepmania.com/download.php?f ... down.smzip
On beginning arrows "jump" from down to top oO . Bug only in ver 1.4+. Look On chellenge mode.

In setting i off holds, i change music ofset -325, show score in %, fullscren on.

Tested on samsung i5700.

Bug confirmed. The bug is due to the music offset. If the music offset is anything other than 0, there is the weird jump. This is probably because I forgot to account for the offset in the initial countdown (and didn't notice the bug since most songs have a few seconds of blank time before the notes start falling down). Will also look into fixing that, thanks!

Update: Bug fixed, just a simple "+ manualOffset" in one line of code. On an off-topic note, tried the D.Gray-man OP2 stepfiles a few times; the best I got was 41% with a score of 1448750. Its ironic cause if I were to just spam tap arrows, I easily get almost 70% with a score of over 1500000. Stepfiles like these (or at least the Challenge version) are not meant to be played on your phone xD

~Keripo

~Keripo
Image
User avatar
keripo
Site Admin
 
Posts: 115
Joined: Nov 7th, '10, 03:38
Location: [pengp@stwing~]

Re: Bugs in tap detection

Postby burdik on Jan 25th, '11, 07:38

Keripo, my bug is difficult to reproduce cuz it just happens randomly on random notes on random songs etc. But it still persists.
However, since the update, it only happens on "good" taps. So anything you've changed since 1.4 is good 8). And i always turn vibrate off (too... ANNOOOOOYING :D)
-=Russia is very large and cold place somewhere in the Arctics, inhabited by drunken bears firing nukes left, right and center.=-
User avatar
burdik
 
Posts: 19
Joined: Jan 16th, '11, 12:49
Location: Moscow, USSR =D

Re: Bugs in tap detection

Postby Zurek on Jan 25th, '11, 08:16

K, i try see details of the bug :p But is liitle hard :d
User avatar
Zurek
 
Posts: 7
Joined: Jan 22nd, '11, 18:05
Location: Elbląg, Poland

Re: Bugs in tap detection

Postby keripo on Jan 25th, '11, 18:28

burdik wrote:Keripo, my bug is difficult to reproduce cuz it just happens randomly on random notes on random songs etc. But it still persists.
However, since the update, it only happens on "good" taps. So anything you've changed since 1.4 is good 8). And i always turn vibrate off (too... ANNOOOOOYING :D)

Try turning off your background data, killing all other tasks, and putting the app priority to high. After a bit of testing, I was able to attribute a few of those misses to very brief lag spikes (most of which was K9 Mail checking for new emails or me receiving a text message). The possibility of an actual bug is still there, however, just hard to hunt down if I can't replicate it reliably...

For the next version, I will look into more ways of preventing lag spikes.
Image
User avatar
keripo
Site Admin
 
Posts: 115
Joined: Nov 7th, '10, 03:38
Location: [pengp@stwing~]

Re: Bugs in tap detection

Postby burdik on Jan 26th, '11, 17:01

That wasn't a lag. In such cases an arrow just doesn't go away and goes down and causes a miss >_<
I had ~58-59 fps, turned background data off, phone off and wifi and bt off
And now i'm downgrading my ROM to FroyoMOD 2.2 to try 4point multitouch, lol
-=Russia is very large and cold place somewhere in the Arctics, inhabited by drunken bears firing nukes left, right and center.=-
User avatar
burdik
 
Posts: 19
Joined: Jan 16th, '11, 12:49
Location: Moscow, USSR =D


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest